patchclamp:  making patching easier

Hardware and software requirements

1. You will need essentially any dual-core CPU running at 1.5 GHz core frequency at least. The primary testing PC is running on Celeron J3455 CPU and development is done on RyZen 5 3600. Even old CPUs like Pentium 4 or AMD E-350 might be OK.


2. Anything from 1 to 16 Gb of RAM should be enough, depending on the amount of data you process.


3. A DAQ card supported by Comedi is required. Please see the list, and if unsure, get in touch with a local guru or me.


4. Linux with installed Qt 4.5 (switch to Qt 5 pending) and Comedi. The development  is done on a PC running the most recent  Kubuntu Linux. You might have least trouble if you use it or any other Debian-based distribution with KDE as desktop environment.


5. The program design philosophy bases on working from RAM. Therefore I would not be surprised if someone would  run it from a server - or an USB stick!


6. High quality power supply unit is essential for low-noise recordings.  My personal recommendation will be to look at the 400-500 W PSU from the upper half of the price range; I tend to prefer FSP brand but other might work too. Just don't go for the cheap ones to be safe.

© Copyright 2012 Vadim Alexeenko. All Rights Reserved.